Register a Game Account Image - Join our Discord Server Image
Note: Your forum account is not your in-game account. You must register a separate game account to play, then sign into the game with that account.

Have any questions? Need help with something? Contact us on Discord or check out our Help Forums.

Announcement: We have updated our multiple accounts policy. Please read here and submit the required information if your household plays on more than one account.

Donations are always welcome and help us with the upkeep of the server. Click the "Donate Now" link above, or click here to donate. Thank you!


Help us stay #1 and vote for us Here and Come Join Us on Twitter

Installing on Mac

Post Reply
User avatar
Elo
Senior Commander
Posts: 65
Joined: Mon Oct 22, 2018 12:43 pm
United States of America

Installing on Mac

#1

Post by Elo » Tue Oct 23, 2018 8:04 am

[EDIT] I have been working on this for a while now, and it is pretty clear that it is a problem with Wine playing nicely with the launchpad. In other words, I'm sure this is unique to me using my Mac. I'll post an update if I get it working, but I don't expect anyone will be able to help me out here.

I got SWGEmu working on my mac using Wine. I'm trying to do the same thing here for the launcher, but get stuck with the following error ("A Javascript error occurred in the main process").
Screen Shot 2018-10-23 at 13.28.11.png
It is strange that I was easily able to install the launcher but cannot actually run it.

My (admittedly limited) research on this specific error suggests a problem with the code itself, but I assume that others have run the launcher without this issue.

Any suggestions would be appreciated!
You do not have the required permissions to view the files attached to this post.

User avatar
Tyclo
Developer
Posts: 193
Joined: Mon Jan 01, 2018 10:08 pm
Location: Las Vegas, NV
United States of America

Re: Installing on Mac

#2

Post by Tyclo » Tue Oct 23, 2018 9:12 pm

Hi Elo,
Our launcher is brand new and developed using Electron, which is a JavaScript framework. This makes our launcher very different from the SWGEmu's launcher, which is C family language, or something of the like. I've considered MacOS, Unix and Wine in the design process, but they aren't officially supported.

The error message you are getting is occurring right as the program launches on one of it's first actions, where it tries to create a configuration file. It can't locate a default directory to create the config file to (Because of Wine), so it attempts to display a graceful warning message in an "alert" window. But then the warning message fails critically because of Wine. (So much for being graceful...)

The fact that an alert window is throwing an error means that nothing is probably going to work. I have both a MacOS and Linux machine to try and resolve this on, but I can't guarantee anything and except a whack-a-mole style bug fix routine. Being electron, there's a possibility that I can make it a native MacOS application, but time is my most valuable asset with a project like this.

What I suggest is running W10 in Bootcamp or a Windows 10 VM. Bootcamp will be the best performance wise, but a VM is most certainly the easiest. Although both require a Windows 10 license.

Alternatively, I can provide you with a manual installation and you can extract the files and run SWGEmu.exe directly, but updating will be a problem unless I can find a solution for the launcher not running in Wine.

User avatar
Elo
Senior Commander
Posts: 65
Joined: Mon Oct 22, 2018 12:43 pm
United States of America

Re: Installing on Mac

#3

Post by Elo » Tue Oct 23, 2018 11:09 pm

Tyclo,

First of all, you rock.

I know that bootcamp would be the simplest solution, however W10 is expensive and I’d rather spend that money on donations or something more useful if I can get away with it.

I had thought about asking for a manual install but realized it would become a problem with every update, as you mentioned.

For now, I may need to just watch and wait. I’ll keep brainstorming.

Thanks!

[EDIT] You may be able to put me to work if you want... my time is limited and sporadic (medical student) but I used to develop websites and lately I’ve been working on iOS apps. Let me know if that’s an option.

User avatar
Tyclo
Developer
Posts: 193
Joined: Mon Jan 01, 2018 10:08 pm
Location: Las Vegas, NV
United States of America

Re: Installing on Mac

#4

Post by Tyclo » Wed Oct 24, 2018 1:40 am

Haha, thanks.

Yeah, licenses aren't cheap. My current W10 machine runs a license I got for free as Windows 7 from college almost ~8 years ago, lol. Perks of being an IT student.

I'm due to publish an update to the launcher within the next week or so, I'll take a look and see if there's anything I can do. After some review, I think I can solve a few of the issues with a few careful modifications, so hope is not lost. The solution to the problem will all be in the launcher code. If I can get a simple fix ready I'll let you know. I'm just expecting 100 other problems after fixing the first one, lol.

I've sent you a PM with a manual install just in case you'd like to give that a try while I see if I can fix the launcher for Wine.

Ah cool. Web Development is my primary line of work. I've never worked with iOS or Swift, but we run on C++ with the core3 SWGEmu code. Web-wise, I just redid the SR website, which was a fun little project. More graphics than programming though.

This is the public repo for the launcher: https://github.com/DesporoWace/SR-Launcher (Yes, I know about the typo in the Readme lol)

If you're curious, what's killing your launcher is line 15 here: https://github.com/DesporoWace/SR-Launc ... er/main.js
Adding window.alert() would probably fix your problem, but I'm going to replace it entirely.

User avatar
Elo
Senior Commander
Posts: 65
Joined: Mon Oct 22, 2018 12:43 pm
United States of America

Re: Installing on Mac

#5

Post by Elo » Wed Oct 24, 2018 11:33 am

Good work! The website is super slick. I was looking for a phpbb addon to allow for push notifications (for PMs etc), but I had to go to work haha

Awesome, I’ll check out the GIT soon.

[EDIT] Ah, yeah I actually found that line in the code and tried changing it to print instead of alert. It seemed to work (or maybe it didn't) but it brought up new/different errors. That's when I realized it was a rabbit hole that I didn't have time to go down...yet

Naison
Midshipman
Posts: 4
Joined: Fri Oct 18, 2019 4:45 pm
United States of America

Re: Installing on Mac

#6

Post by Naison » Fri Oct 18, 2019 10:23 pm

Any update on this? I am on linux and actually found this error and have tried using wine a couple different ways,
Screenshot from 2019-10-18 17-25-35.png
making a 32bit directory/installing to its own directory/an update that seemed to fix the issue for someone else with EiF...

Just wanted to know if there was any headway made on this? I am not one with extensive knowledge in coding, but I can lend a helping hand!

UPDATE:
I got to this screen. So all I did was create a wine directory and add corefonts with winetricks
Screenshot from 2019-10-18 17-26-47.png
WINEPREFIX=~/.SREmu WINEARCH=win32 winetricks corefonts
WINEPREFIX=~/.SREmu wine Downloads/SREmu.exe

I got the error but as soon as I clicked "Ok" it opened up the splash screen.
You do not have the required permissions to view the files attached to this post.

Naison
Midshipman
Posts: 4
Joined: Fri Oct 18, 2019 4:45 pm
United States of America

Re: Installing on Mac

#7

Post by Naison » Sat Oct 19, 2019 1:04 am

Naison wrote:
Fri Oct 18, 2019 10:23 pm
Any update on this? I am on linux and actually found this error and have tried using wine a couple different ways,
Screenshot from 2019-10-18 17-25-35.png
making a 32bit directory/installing to its own directory/an update that seemed to fix the issue for someone else with EiF...

Just wanted to know if there was any headway made on this? I am not one with extensive knowledge in coding, but I can lend a helping hand!

UPDATE:
I got to this screen. So all I did was create a wine directory and add corefonts with winetricks
Screenshot from 2019-10-18 17-26-47.png

WINEPREFIX=~/.SREmu WINEARCH=win32 winetricks corefonts
WINEPREFIX=~/.SREmu wine Downloads/SREmu.exe

I got the error but as soon as I clicked "Ok" it opened up the splash screen.
I did it! I got it to run on Linux, I will update with a brand new post to show how!

Naison
Midshipman
Posts: 4
Joined: Fri Oct 18, 2019 4:45 pm
United States of America

Re: Installing on Mac

#8

Post by Naison » Sat Oct 19, 2019 2:21 am

Naison wrote:
Sat Oct 19, 2019 1:04 am
Naison wrote:
Fri Oct 18, 2019 10:23 pm
Any update on this? I am on linux and actually found this error and have tried using wine a couple different ways,
Screenshot from 2019-10-18 17-25-35.png
making a 32bit directory/installing to its own directory/an update that seemed to fix the issue for someone else with EiF...

Just wanted to know if there was any headway made on this? I am not one with extensive knowledge in coding, but I can lend a helping hand!

UPDATE:
I got to this screen. So all I did was create a wine directory and add corefonts with winetricks
Screenshot from 2019-10-18 17-26-47.png

WINEPREFIX=~/.SREmu WINEARCH=win32 winetricks corefonts
WINEPREFIX=~/.SREmu wine Downloads/SREmu.exe

I got the error but as soon as I clicked "Ok" it opened up the splash screen.
I did it! I got it to run on Linux, I will update with a brand new post to show how!
Here is a link to my method. Hope it helps!

https://swgsremu.com/forum/viewtopic.php?f=63&t=1856

Post Reply